Java security warning

Discussion of updates and test versions

Moderator: domino

Java security warning

Postby Jpd Gemni » Sat Oct 23, 2010 11:58 am

We’re now getting a (latest Sun/Oracle) Java security warning on our clients' websites (and on our local machines), saying that the CCXWORD or GRID security certificate has expired. You can still click ‘No’ to load the applet, but this must be worrying for users. Will there be an update to fix this please?
Jpd Gemni
 
Posts: 3
Joined: Sat Oct 23, 2010 11:48 am

Re: Java security warning

Postby Antony Lewis » Sun Oct 24, 2010 6:42 pm

The Java applet is not signed, so it shouldn't be anything to do with the applet - do you also get with will puzzles at

http://www.crossword-compiler.com/java.html

?
Antony Lewis
Site Admin
 
Posts: 863
Joined: Sat Sep 25, 2004 3:32 pm
Location: Site Admin

Postby Jpd Gemni » Sun Dec 19, 2010 8:43 pm

Sorry for delay replying! Yes, on some PCs the Java security warning happens with all Crossword Compiler applets run on Sun/Oracle Java.

Machines running upgraded and/or re-installed Windows XP SP3 seem the most prone to this error. Fresh Windows 7 machines seem ok.

The answer is here:
http://www.java.com/en/download/help/er ... edcode.xml

So you go to the Windows Control Panel, click Java, and on the Advanced tab click Security . . Mixed code, then select 'Enable - hide warning and run with protections'. Then all is well . . . . so far!
Jpd Gemni
 
Posts: 3
Joined: Sat Oct 23, 2010 11:48 am


Return to Crossword Compiler Updates

Who is online

Users browsing this forum: No registered users and 1 guest